Class HttpHeaders
- java.lang.Object
-
- org.springframework.cloud.contract.spec.internal.HttpHeaders
-
public final class HttpHeaders extends Object
Contains most commonly used http headers.- Since:
- 1.0.2
- Author:
- Marcin Grzejszczak, Tim Ysewyn
-
-
Field Summary
Fields Modifier and Type Field Description static StringACCEPTThe HTTPAcceptheader field name.static StringACCEPT_CHARSETThe HTTPAccept-Charsetheader field name.static StringACCEPT_ENCODINGThe HTTPAccept-Encodingheader field name.static StringACCEPT_LANGUAGEThe HTTPAccept-Languageheader field name.static StringACCEPT_RANGESThe HTTPAccept-Rangesheader field name.static StringACCESS_CONTROL_ALLOW_CREDENTIALSThe CORSAccess-Control-Allow-Credentialsresponse header field name.static StringACCESS_CONTROL_ALLOW_HEADERSThe CORSAccess-Control-Allow-Headersresponse header field name.static StringACCESS_CONTROL_ALLOW_METHODSThe CORSAccess-Control-Allow-Methodsresponse header field name.static StringACCESS_CONTROL_ALLOW_ORIGINThe CORSAccess-Control-Allow-Originresponse header field name.static StringACCESS_CONTROL_EXPOSE_HEADERSThe CORSAccess-Control-Expose-Headersresponse header field name.static StringACCESS_CONTROL_MAX_AGEThe CORSAccess-Control-Max-Ageresponse header field name.static StringACCESS_CONTROL_REQUEST_HEADERSThe CORSAccess-Control-Request-Headersrequest header field name.static StringACCESS_CONTROL_REQUEST_METHODThe CORSAccess-Control-Request-Methodrequest header field name.static StringAGEThe HTTPAgeheader field name.static StringALLOWThe HTTPAllowheader field name.static StringAUTHORIZATIONThe HTTPAuthorizationheader field name.static StringCACHE_CONTROLThe HTTPCache-Controlheader field name.static StringCONNECTIONThe HTTPConnectionheader field name.static StringCONTENT_DISPOSITIONThe HTTPContent-Dispositionheader field name.static StringCONTENT_ENCODINGThe HTTPContent-Encodingheader field name.static StringCONTENT_LANGUAGEThe HTTPContent-Languageheader field name.static StringCONTENT_LENGTHThe HTTPContent-Lengthheader field name.static StringCONTENT_LOCATIONThe HTTPContent-Locationheader field name.static StringCONTENT_RANGEThe HTTPContent-Rangeheader field name.static StringCONTENT_TYPEThe HTTPContent-Typeheader field name.static StringCOOKIEThe HTTPCookieheader field name.static StringDATEThe HTTPDateheader field name.static StringETAGThe HTTPETagheader field name.static StringEXPECTThe HTTPExpectheader field name.static StringEXPIRESThe HTTPExpiresheader field name.static StringFROMThe HTTPFromheader field name.static StringHOSTThe HTTPHostheader field name.static StringIF_MATCHThe HTTPIf-Matchheader field name.static StringIF_MODIFIED_SINCEThe HTTPIf-Modified-Sinceheader field name.static StringIF_NONE_MATCHThe HTTPIf-None-Matchheader field name.static StringIF_RANGEThe HTTPIf-Rangeheader field name.static StringIF_UNMODIFIED_SINCEThe HTTPIf-Unmodified-Sinceheader field name.static StringLAST_MODIFIEDThe HTTPLast-Modifiedheader field name.static StringLINKThe HTTPLinkheader field name.static StringLOCATIONThe HTTPLocationheader field name.static StringMAX_FORWARDSThe HTTPMax-Forwardsheader field name.static StringORIGINThe HTTPOriginheader field name.static StringPRAGMAThe HTTPPragmaheader field name.static StringPROXY_AUTHENTICATEThe HTTPProxy-Authenticateheader field name.static StringPROXY_AUTHORIZATIONThe HTTPProxy-Authorizationheader field name.static StringRANGEThe HTTPRangeheader field name.static StringREFERERThe HTTPRefererheader field name.static StringRETRY_AFTERThe HTTPRetry-Afterheader field name.static StringSERVERThe HTTPServerheader field name.static StringSET_COOKIEThe HTTPSet-Cookieheader field name.static StringSET_COOKIE_2The HTTPSet-Cookie2header field name.static StringTEThe HTTPTEheader field name.static StringTRAILERThe HTTPTrailerheader field name.static StringTRANSFER_ENCODINGThe HTTPTransfer-Encodingheader field name.static StringUPGRADEThe HTTPUpgradeheader field name.static StringUSER_AGENTThe HTTPUser-Agentheader field name.static StringVARYThe HTTPVaryheader field name.static StringVIAThe HTTPViaheader field name.static StringWARNINGThe HTTPWarningheader field name.static StringWWW_AUTHENTICATEThe HTTPWWW-Authenticateheader field name.
-
Constructor Summary
Constructors Constructor Description HttpHeaders()
-
-
-
Field Detail
-
ACCEPT
public static final String ACCEPT
The HTTPAcceptheader field name.- See Also:
- Section 5.3.2 of RFC 7231, Constant Field Values
-
ACCEPT_CHARSET
public static final String ACCEPT_CHARSET
The HTTPAccept-Charsetheader field name.- See Also:
- Section 5.3.3 of RFC 7231, Constant Field Values
-
ACCEPT_ENCODING
public static final String ACCEPT_ENCODING
The HTTPAccept-Encodingheader field name.- See Also:
- Section 5.3.4 of RFC 7231, Constant Field Values
-
ACCEPT_LANGUAGE
public static final String ACCEPT_LANGUAGE
The HTTPAccept-Languageheader field name.- See Also:
- Section 5.3.5 of RFC 7231, Constant Field Values
-
ACCEPT_RANGES
public static final String ACCEPT_RANGES
The HTTPAccept-Rangesheader field name.- See Also:
- Section 5.3.5 of RFC 7233, Constant Field Values
-
ACCESS_CONTROL_ALLOW_CREDENTIALS
public static final String ACCESS_CONTROL_ALLOW_CREDENTIALS
The CORSAccess-Control-Allow-Credentialsresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_ALLOW_HEADERS
public static final String ACCESS_CONTROL_ALLOW_HEADERS
The CORSAccess-Control-Allow-Headersresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_ALLOW_METHODS
public static final String ACCESS_CONTROL_ALLOW_METHODS
The CORSAccess-Control-Allow-Methodsresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_ALLOW_ORIGIN
public static final String ACCESS_CONTROL_ALLOW_ORIGIN
The CORSAccess-Control-Allow-Originresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_EXPOSE_HEADERS
public static final String ACCESS_CONTROL_EXPOSE_HEADERS
The CORSAccess-Control-Expose-Headersresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_MAX_AGE
public static final String ACCESS_CONTROL_MAX_AGE
The CORSAccess-Control-Max-Ageresponse header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_REQUEST_HEADERS
public static final String ACCESS_CONTROL_REQUEST_HEADERS
The CORSAccess-Control-Request-Headersrequest header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
ACCESS_CONTROL_REQUEST_METHOD
public static final String ACCESS_CONTROL_REQUEST_METHOD
The CORSAccess-Control-Request-Methodrequest header field name.- See Also:
- CORS W3C recommendation, Constant Field Values
-
AGE
public static final String AGE
The HTTPAgeheader field name.- See Also:
- Section 5.1 of RFC 7234, Constant Field Values
-
ALLOW
public static final String ALLOW
The HTTPAllowheader field name.- See Also:
- Section 7.4.1 of RFC 7231, Constant Field Values
-
AUTHORIZATION
public static final String AUTHORIZATION
The HTTPAuthorizationheader field name.- See Also:
- Section 4.2 of RFC 7235, Constant Field Values
-
CACHE_CONTROL
public static final String CACHE_CONTROL
The HTTPCache-Controlheader field name.- See Also:
- Section 5.2 of RFC 7234, Constant Field Values
-
CONNECTION
public static final String CONNECTION
The HTTPConnectionheader field name.- See Also:
- Section 6.1 of RFC 7230, Constant Field Values
-
CONTENT_ENCODING
public static final String CONTENT_ENCODING
The HTTPContent-Encodingheader field name.- See Also:
- Section 3.1.2.2 of RFC 7231, Constant Field Values
-
CONTENT_DISPOSITION
public static final String CONTENT_DISPOSITION
The HTTPContent-Dispositionheader field name.- See Also:
- RFC 6266, Constant Field Values
-
CONTENT_LANGUAGE
public static final String CONTENT_LANGUAGE
The HTTPContent-Languageheader field name.- See Also:
- Section 3.1.3.2 of RFC 7231, Constant Field Values
-
CONTENT_LENGTH
public static final String CONTENT_LENGTH
The HTTPContent-Lengthheader field name.- See Also:
- Section 3.3.2 of RFC 7230, Constant Field Values
-
CONTENT_LOCATION
public static final String CONTENT_LOCATION
The HTTPContent-Locationheader field name.- See Also:
- Section 3.1.4.2 of RFC 7231, Constant Field Values
-
CONTENT_RANGE
public static final String CONTENT_RANGE
The HTTPContent-Rangeheader field name.- See Also:
- Section 4.2 of RFC 7233, Constant Field Values
-
CONTENT_TYPE
public static final String CONTENT_TYPE
The HTTPContent-Typeheader field name.- See Also:
- Section 3.1.1.5 of RFC 7231, Constant Field Values
-
COOKIE
public static final String COOKIE
The HTTPCookieheader field name.- See Also:
- Section 4.3.4 of RFC 2109, Constant Field Values
-
DATE
public static final String DATE
The HTTPDateheader field name.- See Also:
- Section 7.1.1.2 of RFC 7231, Constant Field Values
-
ETAG
public static final String ETAG
The HTTPETagheader field name.- See Also:
- Section 2.3 of RFC 7232, Constant Field Values
-
EXPECT
public static final String EXPECT
The HTTPExpectheader field name.- See Also:
- Section 5.1.1 of RFC 7231, Constant Field Values
-
EXPIRES
public static final String EXPIRES
The HTTPExpiresheader field name.- See Also:
- Section 5.3 of RFC 7234, Constant Field Values
-
FROM
public static final String FROM
The HTTPFromheader field name.- See Also:
- Section 5.5.1 of RFC 7231, Constant Field Values
-
HOST
public static final String HOST
The HTTPHostheader field name.- See Also:
- Section 5.4 of RFC 7230, Constant Field Values
-
IF_MATCH
public static final String IF_MATCH
The HTTPIf-Matchheader field name.- See Also:
- Section 3.1 of RFC 7232, Constant Field Values
-
IF_MODIFIED_SINCE
public static final String IF_MODIFIED_SINCE
The HTTPIf-Modified-Sinceheader field name.- See Also:
- Section 3.3 of RFC 7232, Constant Field Values
-
IF_NONE_MATCH
public static final String IF_NONE_MATCH
The HTTPIf-None-Matchheader field name.- See Also:
- Section 3.2 of RFC 7232, Constant Field Values
-
IF_RANGE
public static final String IF_RANGE
The HTTPIf-Rangeheader field name.- See Also:
- Section 3.2 of RFC 7233, Constant Field Values
-
IF_UNMODIFIED_SINCE
public static final String IF_UNMODIFIED_SINCE
The HTTPIf-Unmodified-Sinceheader field name.- See Also:
- Section 3.4 of RFC 7232, Constant Field Values
-
LAST_MODIFIED
public static final String LAST_MODIFIED
The HTTPLast-Modifiedheader field name.- See Also:
- Section 2.2 of RFC 7232, Constant Field Values
-
LINK
public static final String LINK
The HTTPLinkheader field name.- See Also:
- RFC 5988, Constant Field Values
-
LOCATION
public static final String LOCATION
The HTTPLocationheader field name.- See Also:
- Section 7.1.2 of RFC 7231, Constant Field Values
-
MAX_FORWARDS
public static final String MAX_FORWARDS
The HTTPMax-Forwardsheader field name.- See Also:
- Section 5.1.2 of RFC 7231, Constant Field Values
-
ORIGIN
public static final String ORIGIN
The HTTPOriginheader field name.- See Also:
- RFC 6454, Constant Field Values
-
PRAGMA
public static final String PRAGMA
The HTTPPragmaheader field name.- See Also:
- Section 5.4 of RFC 7234, Constant Field Values
-
PROXY_AUTHENTICATE
public static final String PROXY_AUTHENTICATE
The HTTPProxy-Authenticateheader field name.- See Also:
- Section 4.3 of RFC 7235, Constant Field Values
-
PROXY_AUTHORIZATION
public static final String PROXY_AUTHORIZATION
The HTTPProxy-Authorizationheader field name.- See Also:
- Section 4.4 of RFC 7235, Constant Field Values
-
RANGE
public static final String RANGE
The HTTPRangeheader field name.- See Also:
- Section 3.1 of RFC 7233, Constant Field Values
-
REFERER
public static final String REFERER
The HTTPRefererheader field name.- See Also:
- Section 5.5.2 of RFC 7231, Constant Field Values
-
RETRY_AFTER
public static final String RETRY_AFTER
The HTTPRetry-Afterheader field name.- See Also:
- Section 7.1.3 of RFC 7231, Constant Field Values
-
SERVER
public static final String SERVER
The HTTPServerheader field name.- See Also:
- Section 7.4.2 of RFC 7231, Constant Field Values
-
SET_COOKIE
public static final String SET_COOKIE
The HTTPSet-Cookieheader field name.- See Also:
- Section 4.2.2 of RFC 2109, Constant Field Values
-
SET_COOKIE_2
public static final String SET_COOKIE_2
The HTTPSet-Cookie2header field name.- See Also:
- RFC 2965, Constant Field Values
-
TE
public static final String TE
The HTTPTEheader field name.- See Also:
- Section 4.3 of RFC 7230, Constant Field Values
-
TRAILER
public static final String TRAILER
The HTTPTrailerheader field name.- See Also:
- Section 4.4 of RFC 7230, Constant Field Values
-
TRANSFER_ENCODING
public static final String TRANSFER_ENCODING
The HTTPTransfer-Encodingheader field name.- See Also:
- Section 3.3.1 of RFC 7230, Constant Field Values
-
UPGRADE
public static final String UPGRADE
The HTTPUpgradeheader field name.- See Also:
- Section 6.7 of RFC 7230, Constant Field Values
-
USER_AGENT
public static final String USER_AGENT
The HTTPUser-Agentheader field name.- See Also:
- Section 5.5.3 of RFC 7231, Constant Field Values
-
VARY
public static final String VARY
The HTTPVaryheader field name.- See Also:
- Section 7.1.4 of RFC 7231, Constant Field Values
-
VIA
public static final String VIA
The HTTPViaheader field name.- See Also:
- Section 5.7.1 of RFC 7230, Constant Field Values
-
WARNING
public static final String WARNING
The HTTPWarningheader field name.- See Also:
- Section 5.5 of RFC 7234, Constant Field Values
-
WWW_AUTHENTICATE
public static final String WWW_AUTHENTICATE
The HTTPWWW-Authenticateheader field name.- See Also:
- Section 4.1 of RFC 7235, Constant Field Values
-
-